Slowness in Parishsoft Accounting
Incident Report for ParishSOFT Products
Resolved
After continuing to monitor for a month we have seen no instances of slowness related to the original root cause. This issue is resolved.
Posted Mar 30, 2021 - 09:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2021 - 09:48 EST
Investigating
We are currently investigating this issue.
Posted Dec 02, 2020 - 14:59 EST
This incident affected: ParishSOFT Accounting.