Incoming Call Outage
Incident Report for ParishSOFT Products
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 09:13 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 14, 2019 - 09:44 EDT
Identified
Currently the ParishSOFT Ann Arbor support call center is experiencing difficulties receiving incoming phone calls.
Posted Oct 11, 2019 - 16:04 EDT
This incident affected: ParishSOFT Support Call Center.