OLG Partial Failed Processing
Incident Report for ParishSOFT Products
Resolved
This incident has been resolved.
Posted Jun 03, 2019 - 10:43 EDT
Investigating
We are currently investigating this issue.
Posted May 24, 2019 - 10:10 EDT
This incident affected: Giving Systems (ParishSOFT Legacy Online Giving).