RS 2.0 Limited Outage
Incident Report for ParishSOFT Products
Resolved
This incident has been resolved.
Posted Jun 12, 2018 - 11:54 EDT
Investigating
We are currently investigating this issue.
Posted Jun 12, 2018 - 11:11 EDT
This incident affected: Legacy Systems (ParishSOFT Remote Solutions - System 1).