Partial Outage For ParishSOFT Family Suite and Accounting
Incident Report for ParishSOFT Products
Resolved
This incident has been resolved.
Posted Jun 14, 2018 - 11:12 EDT
Investigating
We are currently investigating this issue.
Posted Jun 14, 2018 - 10:34 EDT
This incident affected: ParishSOFT Family Suite and ParishSOFT Accounting.