RS 2.0 Unable to access mapped drives and desktop icons
Incident Report for ParishSOFT Products
Resolved
This incident has been resolved.
Posted Nov 29, 2018 - 16:18 EST
Investigating
We are currently investing this issue.
Posted Nov 29, 2018 - 10:02 EST
This incident affected: Legacy Systems (ParishSOFT Remote Solutions - System 2).